Fork me on GitHub

PMD Results

The following document contains the results of PMD 5.3.5.

Files

fr/paris/lutece/plugins/unittree/modules/notification/business/INotificationDAO.java

Violation Line
Avoid modifiers which are implied by the context 43

fr/paris/lutece/plugins/unittree/modules/notification/business/Notification.java

Violation Line
Avoid using redundant field initializer for '_bHasNotif' 43
Avoid using redundant field initializer for '_bUseEmail' 44
Avoid using redundant field initializer for '_bUseList' 45
A getX() method which returns a boolean should be named isX() 8487
A getX() method which returns a boolean should be named isX() 101104
A getX() method which returns a boolean should be named isX() 118121

fr/paris/lutece/plugins/unittree/modules/notification/business/NotificationDAO.java

Violation Line
This final field could be made static 44
This final field could be made static 45
This final field could be made static 47
This final field could be made static 48

fr/paris/lutece/plugins/unittree/modules/notification/service/NotificationService.java

Violation Line
Deeply nested if..then statements are hard to read 214217
Deeply nested if..then statements are hard to read 219228