Fork me on GitHub

PMD Results

The following document contains the results of PMD 5.3.5.

Files

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/business/TaskNotifyCRMConfig.java

Violation Line
A getX() method which returns a boolean should be named isX() 151154

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/business/TaskNotifyCRMConfigDAO.java

Violation Line
No need to import a type that lives in the same package 38
Use block level rather than method level synchronization 5772

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/service/INotifyCRMService.java

Violation Line
Avoid modifiers which are implied by the context 45
Avoid modifiers which are implied by the context 46
Avoid modifiers which are implied by the context 47
Avoid modifiers which are implied by the context 48

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/service/IdeationNotifyCRMService.java

Violation Line
If you run in Java5 or newer and have concurrent access, you should use the ConcurrentHashMap implementation 66

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/service/NotifyCRMNoEsbPlugin.java

Violation Line
All methods are static. Consider using a utility class instead. Alternatively, you could add a private constructor or make the class abstract to silence this warning. 4758

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/service/taskinfo/NotifyCRMTaskInfoProvider.java

Violation Line
Avoid variables with short names like t 97

fr/paris/lutece/plugins/workflow/modules/notifycrmnoesb/web/NotifyCRMTaskComponent.java

Violation Line
Substitute calls to size() == 0 (or size() != 0, size() > 0, size() < 1) with calls to isEmpty() 113
If you run in Java5 or newer and have concurrent access, you should use the ConcurrentHashMap implementation 140