Résultats PMD
Le document suivant contient les résultats de PMD 5.3.5.
Fichiers
fr/paris/lutece/plugins/searchldap/service/LDAPLuteceUserProviderService.java
Violation |
Ligne |
Use of modifier volatile is not recommended. |
53 |
A getX() method which returns a boolean should be named isX() |
117–126 |
fr/paris/lutece/plugins/searchldap/service/LDAPUserNotFoundCacheService.java
Violation |
Ligne |
It is a good practice to call super() in a constructor |
51–54 |
fr/paris/lutece/plugins/searchldap/service/LdapBrowser.java
Violation |
Ligne |
The class 'LdapBrowser' has a Cyclomatic Complexity of 2 (Highest = 10). |
62–314 |
Use of modifier volatile is not recommended. |
89 |
Avoid unnecessary constructors - the compiler will generate these for you |
94–96 |
Document empty constructor |
94–96 |
The method 'getUserPublicData' has a Cyclomatic Complexity of 10. |
103–188 |
Avoid variables with short names like sr |
106 |
Avoid variables with short names like sb |
197 |
StringBuffer constructor is initialized with size 16, but has at least 26 characters appended. |
197 |
StringBuffer (or StringBuilder).append is called consecutively without reusing the target variable. |
198 |
StringBuffer (or StringBuilder).append is called consecutively without reusing the target variable. |
199 |
StringBuffer (or StringBuilder).append is called consecutively without reusing the target variable. |
200 |
Use block level rather than method level synchronization |
281–313 |
fr/paris/lutece/plugins/searchldap/service/LdapUtil.java
Violation |
Ligne |
Rather than using a lot of String arguments, consider using a container object for those values. |
69–70 |
Consider replacing this Hashtable with the newer java.util.Map |
72 |
Rather than using a lot of String arguments, consider using a container object for those values. |
107 |
Consider replacing this Hashtable with the newer java.util.Map |
112 |
Avoid variables with short names like sc |
135 |