PMD Results
The following document contains the results of PMD 5.3.5.
Files
fr/paris/lutece/plugins/uploadimage/business/Options.java
Violation |
Line |
This class has a bunch of public methods and attributes |
34–507 |
Avoid unused imports such as 'javax.validation.constraints' |
36 |
Avoid unused imports such as 'org.hibernate.validator.constraints' |
37 |
Too many fields |
43–507 |
A getX() method which returns a boolean should be named isX() |
118–121 |
A getX() method which returns a boolean should be named isX() |
135–138 |
A getX() method which returns a boolean should be named isX() |
152–155 |
A getX() method which returns a boolean should be named isX() |
169–172 |
A getX() method which returns a boolean should be named isX() |
186–189 |
A getX() method which returns a boolean should be named isX() |
203–206 |
A getX() method which returns a boolean should be named isX() |
220–223 |
A getX() method which returns a boolean should be named isX() |
237–240 |
A getX() method which returns a boolean should be named isX() |
254–257 |
A getX() method which returns a boolean should be named isX() |
271–274 |
A getX() method which returns a boolean should be named isX() |
288–291 |
A getX() method which returns a boolean should be named isX() |
305–308 |
A getX() method which returns a boolean should be named isX() |
322–325 |
A getX() method which returns a boolean should be named isX() |
339–342 |
A getX() method which returns a boolean should be named isX() |
356–359 |
A getX() method which returns a boolean should be named isX() |
373–376 |
A getX() method which returns a boolean should be named isX() |
390–393 |
Avoid variables with short names like nX |
450 |
Avoid variables with short names like nY |
467 |
fr/paris/lutece/plugins/uploadimage/service/IImageService.java
Violation |
Line |
Avoid modifiers which are implied by the context |
7 |
fr/paris/lutece/plugins/uploadimage/service/UploadImageCacheService.java
Violation |
Line |
It is a good practice to call super() in a constructor |
17–20 |
fr/paris/lutece/plugins/uploadimage/web/ManageUploadimageJspBean.java
Violation |
Line |
Do not add empty strings |
126 |
Do not add empty strings |
154 |
Avoid variables with short names like nX |
185 |
Avoid variables with short names like nY |
186 |
The String literal "action" appears 4 times in this file; the first occurrence is on line 193 |
193 |
Position literals first in String comparisons |
222 |
fr/paris/lutece/plugins/uploadimage/web/UploadimageApp.java
Violation |
Line |
Avoid unused imports such as 'fr.paris.lutece.portal.service.util.AppPathService' |
44 |
Avoid unused imports such as 'fr.paris.lutece.portal.service.util.AppPathService' |
44 |
Avoid unused imports such as 'org.apache.commons.lang.StringUtils' |
52 |
Avoid unused imports such as 'org.apache.commons.lang.StringUtils' |
52 |
Avoid unused private fields such as 'IDOPTION'. |
67 |
If you run in Java5 or newer and have concurrent access, you should use the ConcurrentHashMap implementation |
80 |
If you run in Java5 or newer and have concurrent access, you should use the ConcurrentHashMap implementation |
110 |